Plötzliche Feed-Probleme RSS

Ich musste soeben feststellen, dass ein sehr oft gelesener Beitrag nicht korrekt funktioniert. Mit den Suchbegriffen „Standardabweichung Schäferlauf“ bin ich im Moment auf Platz 1 und 2 bei Google. Der erste Treffer funktioniert – kein Thema, der zweite Treffer zielt direkt auf wp-commentsrss2.php, also auf die Kommentare. Dieser Link funktioniert nicht.

Meldung im Firefox:

XML-Verarbeitungsfehler:
XML-Deklaration nicht am Beginn von externer Entität
Adresse: https://vanclan.de/wp-commentsrss2.php?p=167
Zeile Nr. 2, Spalte 1:<?xml version="1.0" encoding="UTF-8"?>
<!-- generator="wordpress/2.0.3" -->
^

Im Internet Explorer 7 funktioniert der Link einwandfrei… nach ein bisschen Recherche bin ich nicht wirklich weiter. Anfänglich dachte ich, es läge an dem im Titel enthaltenen Umlaut. Daran liegt es nicht, wie das beweist:

Standardabweichung beim Schäferlauf

Unknown Stuntman – Ein Colt für alle Fälle (Colt Seavers)

Beim Colt für alle Fälle sind ja sogar zwei Umlaute drin – trotzdem funktioniert bei diesem.

Wenn ich im IE7 (wo KommentareRSS funktioniert) den Feed im Footer aufrufe, also den eigentlichen Feed der Seite, erhalte ich die Meldung:

Dieser Feed kann nicht angezeigt werden.
Dieser Feed enthält Fehler.
Wechseln Sie zur vorherigen Seite.

Weitere Informationen
Ungültige XML-Deklaration.
Zeile: 2 Zeichen: 3

<?xml version="1.0" encoding="UTF-8"?>

Dies wiederum funktioniert mit Firefox bestens…

Da bis vor kurzem keinerlei Probleme bestanden, habe ich mir mal die letzten Änderungen an der Seite angeschaut. Vor gar nicht allzu langer Zeit habe ich mit den Plugins „Polyglot“ und „Show Recent Comments“ rumgespielt. Polyglot ist allerdings schon wieder deaktiviert. Nach der Deaktivierung vom Kommentarplugin ändert sich erstmal nichts. Deshalb lag der Verdacht an „ImageCounter“, da ich die php-Datei des Plugins wegen Problemen mit Polyglot editiert hatte. Doch auch der Schritt zurück brachte keine Besserung.

So, jetzt bleibt die Frage, warum das oben als erstes beschriebene Problem plötzlich nicht mehr besteht?? Doch Probleme mit „Show Recent Comments“? Aber warum erst eine Stunde nach Deaktivierung behoben…?

Außerdem bleibt Frage 2: Was soll der Spaß mit dem IE7? Wo liegt hier der Fehler? Der Feed Validator bescheinigt mir, dass alles prima ist [Valid RSS]

Passende Artikel

Das könnte Dich auch interessieren …

1 Antwort

  1. Simon sagt:

    Jetzt funktioniert wieder alles!? Ich muss aber dazu sagen, dass ich nichts weiter gemacht habe – nur abgewartet..

    Wenn ich mich recht erinnere, habe ich jetzt nur das Plugin ‚Show Recent Comments‘ deaktiviert.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.

*

Wir setzen auf dieser Seite Cookies ein.

Cookies erleichtern die Bereitstellung unserer Dienste. Mit der Nutzung unserer Dienste erklären Sie sich damit einverstanden, dass wir Cookies verwenden. Tracking-Cookies von Google-Analytics und Facebook (Stand 08/2018 nicht auf diesen Seiten verwendet) können hier deaktiviert werden. Weitere Informationen finden Sie in der Datenschutzerklärung. Diese finden Sie zu jeder Zeit im Seitenfuss aufrufbar.